Subject: Re: CVS commit: pkgsrc
To: Johnny Lam <>
From: Alistair Crooks <>
List: tech-pkg
Date: 09/28/2005 23:06:46
On Wed, Sep 28, 2005 at 06:01:20PM -0400, Johnny Lam wrote:
> Alistair Crooks wrote:
> >
> >So now we have a whole lot of:
> >
> >	NO_BUILD=yes
> >
> >occurrences, which I absolutely detest - it mixes positive and
> >negatives, and always forces me to think twice about what is
> >happenning.
> I also need to look twice when I see mixtures like that.  On this front, 
> I think it's past time to get rid of these NO_* variables and replace 
> them with positive DO_* variables, e.g.:
> 	NO_BUILD=yes		==>	DO_BUILD=no
> 	NO_INSTALL=yes		==>	DO_INSTALL=no
> The DO_* variables could default to "yes" so they don't need to be 
> explicitly set in the vast majority of cases.  This new naming 
> convention would avoid semantic confusion for everyone, myself included.

Unfortunately, the corollary of "great minds think alike" is not
quite so flattering, but I couldn't agree more with you.