Subject: Re: php-sqlite: wrong COMMENT
To: Todd Vierling <>
From: Jaromir Dolecek <>
List: tech-pkg
Date: 09/13/2005 20:28:27
On Mon, Sep 12, 2005 at 03:40:10PM -0400, Todd Vierling wrote:
> In that case, I have no system where I can install php5 without breaking
> things in a major way.  How would I test this change?

It's fine to test-compile only for PHP5.

> > Don't forget to update meta-packages/php?-extensions, too, please.
> OK, will do.  Looking at it now, if the package is *not* updated to work on
> both php4 and php5, I should rename the package "php4-sqlite", right?

Well, yes, but making it work/compile on both php4 and php5 is ~trivial - just
remove the PHP_VERSION_REQD :)

Generally, using the PECL version is preferable and simpler, at
least from pkgsrc maintenance point of view - you deal with only one
version for both PHP environments. Since the majority
of PHP world continues to use PHP4, the PECL package is going to
be better tested then the PHP5-bundled version anyway :)

I'd keep the php-sqlite name, since goal should be to have single pkg
for both php4 and php5. php5-sqlite can be removed later eventually,
php5-extensions might continue to use the (bundled) sqlite driver

Jaromir Dolecek <>  
-=- We can walk our road together if our goals are all the same;     -=-
-=- We can run alone and free if we pursue a different aim.          -=-