Subject: Re: killing gnumeric-1.2
To: None <>
From: Bernd Ernesti <>
List: tech-pkg
Date: 09/06/2005 20:28:20
On Tue, Sep 06, 2005 at 08:07:27PM +0200, Matthias Drochner wrote:
> said:
> > If you do, please move pkgsrc/math/gnumeric14 to pkgsrc/math/gnumeric.
> > 
> I'm always pissed off when someone renames package directories
> forth and back (this breaks pkg_chk and automatic updates, let alone
> local and uncommitted packages), so I'd prefer to turn math/gnumeric
> into a meta package here.

Hmm, I would prefer to have only one package for one software and not multiple,
but sometimes its unavoidable.
What about having a package 'xxxxx' and a 'xxxxx-unstable' if we need a newer
one which is not as stable as the old one, then update the 'xxxxx' one
if the 'xxxxx-unstable' is ok and remove the xxxxx-unstable' at this point?

> > ISTR there were some complaints about one of the two not complaining 
> > (yesterday, by Bernd), please make sure it's not gnumeric14. ;)

It was not really a complaint, I just noticed that it didn't compile and
was looking a little bit into it when I found out that it needs more then
a few patches, so I send a mail.

> It was gnumeric-1.4. I've just committed the fix.

Thank you.

> (I'm just not inclined to do the same tedious work for gnumeric-1.2.)

I can understand that, so lets remove the old version.