Subject: Re: printing with acroread7 and cups
To: Bill Studenmund <>
From: Eric Haszlakiewicz <>
List: tech-pkg
Date: 09/01/2005 16:40:28
On Thu, Sep 01, 2005 at 01:21:38PM -0700, Bill Studenmund wrote:
> On Thu, Sep 01, 2005 at 02:49:29PM -0500, Eric Haszlakiewicz wrote:
> > 	Try running with the patch at:
> >
> > and see if it makes any difference.
> Looking at the right file, I have two questions:
	oops.  I guess I should have tried the link instead of
just typing it from memory. :|

> 1) what exactly are you trying to do? A comment or two would help.

	Erase the emulation root dir from any cwd that has it.  i.e.:
figure out what the emulation dir (e.g. /emul/linux) actually points to.
  (on my machine, and most I think, /usr/pkg/emul/linux)
then see if the path returned from getcwd starts with that
  (e.g. "/usr/pkg/emul/linux/bin")
and if so, remove it.
	(e.g. turning the path into just "/bin"
I'll add some comments.

> 2) Where do you clean up the vnode returned by namei()?
	I thought I needed to do something with it, but I wasn't quite sure what.
I tried vput() immediately after the namei call, since that's what other co=
paths seem to do, but that panic'd with a releasing unlocked lock error.