Subject: Re: NetBSD-current causes package incompatibilities
To: Matthias Scheler <>
From: Quentin Garnier <>
List: tech-pkg
Date: 08/30/2005 11:30:51
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Tue, Aug 30, 2005 at 10:00:52AM +0100, Matthias Scheler wrote:
> > Maybe we could issue a warning when dependencies haven't been compiled
> > under the same OSVERSION, pretty much like pkg_add.
> That sounds like a very good idea. But I think the version check needs
> to be improved. It currently e.g. complains if you install a package
> build under NetBSD 2.1RC1 on a 2.1RC2 or 2.1 system. So we probably
> need an operating system version specific version number processor.

The Linux one will be fun.  I'm so _not_ volunteering :)

As for the principle of it, we can include it in pkg_info(1), just
like the dewey processor.

As for the NetBSD case, the problem is that we're using the kernel
version number for too many things.  (And doesn't pkg_add ignore
the _WHATEVER part now?)  While using the ABI changes to version
-current makes sense, it doesn't map well to the 2.0.1 -> 2.0.2

[Moving to tech-pkg.  There's no reason to keep this private.]

Quentin Garnier - -
"When I find the controls, I'll go where I like, I'll know where I want
to be, but maybe for now I'll stay right here on a silent sea."
KT Tunstall, Silent Sea, Eye to the Telescope, 2004.

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.6 (NetBSD)