Subject: www/php4 on Slackware 10.1
To: None <>
From: Tim Matthews <>
List: tech-pkg
Date: 08/29/2005 15:41:27
hello ...

I'm having a real nasty compiling problem with php 4 on Slackware 10.1. 
I have already tried a lot but still no luck. The error message:

gcc  -Iext/standard/ -I/opt/pkgsrc/www/php4/work/php-4.4.0/ext/standard/ 
-DPHP_ATOM_INC -I/opt/pkgsrc/www/php4/work/php-4.4.0/include 
-I/opt/pkgsrc/www/php4/work/php-4.4.0/Zend    -O2  -c 
/opt/pkgsrc/www/php4/work/php-4.4.0/ext/standard/reg.c -o 
ext/standard/reg.o  && echo > ext/standard/reg.lo
/opt/pkgsrc/www/php4/work/php-4.4.0/ext/standard/reg.c: In function 
/opt/pkgsrc/www/php4/work/php-4.4.0/ext/standard/reg.c:53: error: 
structure has no member named `re_magic'
/opt/pkgsrc/www/php4/work/php-4.4.0/ext/standard/reg.c:72: error: 
structure has no member named `re_magic'
make: *** [ext/standard/reg.lo] Error 1
*** Error code 2

I have already taken off the Slackware gmake and libtool (in the path 
there is the pkgsrc libtool and gmake instead). With this error message 
I still don't understand it's not compiling.

The apache I have in the tree is the apache2 pkg.