Subject: Re: Problems building postgresql80-client on OS X Tiger 10.4.2
To: None <>
From: Caleb Land <>
List: tech-pkg
Date: 08/12/2005 02:57:10
On 8/11/05, Caleb Land <> wrote:
> I'm using pkgsrc for the first time, and I installed it on an OS X
> Tiger 10.4.2 system (Darwin 8.2.0).  Because I'm using
> case-insensative HFS+ I made a UFS diskimage as directed in the pkgsrc
> guide.
> I started by building a simple package, which seemed to work, but when
> I tried to build build postgresql80-client with the command: "sudo
> bmake" I get the following error:
> powerpc-apple-darwin8-gcc-4.0.0: libpq.dylib: No such file or directory*
> I tried building postgresql74-lib package, and that seemed to work fine.
> Has anybody successfully built postgresql80 on OS X, and if so, how was i=
t done?

Okay, I worked around this issue by descening into the
work/postgresql-8.0.3/src/interfaces/ecpg of the postgresql80-client
directory and copying the .dylib files from
work/postgresql-8.0.3/src/interfaces/libpq/.libs into there.  I
haven't tested the workingness of it, but it compiled this time.

> * the full build log file is attached to this mail
> --
> Caleb Land
> (

Caleb Land