Subject: Re: problems building security/PAM on 2.0
To: None <>
From: Johnny Lam <>
List: tech-pkg
Date: 08/10/2005 18:54:29
Jonathan A. Kollasch wrote:
> 	Same problem here (on 2.0.2 as a dependency of Squid), couldn't force it to 
> OpenPAM. Anyway, on 3.0_BETA the need for Linux-PAM is alleviated. Squid 
> built fine with 3.0_BETA's OpenPAM (detected by default).

You should be able to force using OpenPAM by adding the following to 
your /etc/mk.conf:

	PAM_DEFAULT=	openpam

The default pkgsrc PAM is currently Linux-PAM, but since NetBSD>=3.0 has 
OpenPAM integrated, I'll be switching the default to "openpam" after 
I've merged the changes from NetBSD's OpenPAM into the security/openpam 


	-- Johnny Lam <>