Subject: Re: Sun's Java 2 SDK/JRE 1.4.2_08 (64-bit for AMD64)
To: Michael Smith <>
From: David Brownlee <>
List: tech-pkg
Date: 07/23/2005 10:50:34
On Fri, 22 Jul 2005, Michael Smith wrote:

> On Fri, 22 Jul 2005 22:58:49 +0200
> "Robert Cates" <> wrote:
>> I'm about to install NetBSD/AMD64 2.0.2 and would like, actually need,
>> to run Apache Tomcat 5.0.30.  For that I would like to use Sun's Java
>> 2 SDK/JRE 1.4.2_08, but there does not seem to be an AMD64 port.  If I
>> have to I would use the J2SE DK 5.0 Update 4 (jdk-1.5.0_04) for Linux
>> on an AMD64 platform, but...
> It sounds like you are going to have to jump through a few hoops to get
> it to work. Perhaps you could consider porting your application to an
> OSS java runtime. I have used kaffe and I found it surprisingly good,
> but I wouldn't stop looking there.

 	Another option would be to run NetBSD/i386 on the box. We have
 	an amd64 bow in which we only need 2G ram, so the i386 port runs
 	fine with tomcat-5.5.9 and jre15. When we need more than 3GB I'm
 	going to have to move to amd64, but by then the java situation
 	may be much more helpful on NetBSD :)

 		David/absolute       -- No hype required --