Subject: Re: Bogus graphviz dependencies?
To: Greg Troxel <>
From: Richard Rauch <>
List: tech-pkg
Date: 07/21/2005 12:05:29
On Thu, Jul 21, 2005 at 12:11:19PM -0400, Greg Troxel wrote:
>   I got stopped by kdevelop-base wanting graphviz.  graphviz does
>   not have a standard acceptable license for the default pkgsrc
>   LICENSES.  So it stops you cold.
> Make sure you have 1.37 of pkgsrc/graphics/graphviz/Makefile; the
> setting of LICENSE is gone since the license is CPL (an OSI-approved
> license).

I had updated pkgsrc pretty recently.  I guess not recently enough.

Still, as a matter of policy, it looks like this was put in as a
dependency when it should not have been put in.  Maybe it's fine
now, but back when 1.36 of the graphviz Makefile was current, this
was a bad decision.  I am nearly certain that graphviz is at least
as up to date as any of the KDE junk insofar as pkgsrc support is

Anyway, thanks for the reply.  (^&  I'm hesitant to update pkgsrc,
right now, owing to the likely massive rebuilds of applications.
(I did, after all, just install KDE...and kdevelop just finished

  "I probably don't know what I'm talking about."