Subject: Re: Bogus graphviz dependencies?
To: Richard Rauch <>
From: Greg Troxel <>
List: tech-pkg
Date: 07/21/2005 12:11:19
  I got stopped by kdevelop-base wanting graphviz.  graphviz does
  not have a standard acceptable license for the default pkgsrc
  LICENSES.  So it stops you cold.

Make sure you have 1.37 of pkgsrc/graphics/graphviz/Makefile; the
setting of LICENSE is gone since the license is CPL (an OSI-approved

That said, I think it's nice to have PKG_OPTIONS to avoid optional
dependencies if they are big and it's reasonable not to use them.
Doxygen doesn't really need graphviz, and graphviz pulls in tcl/tk.  I
had submitted a patch to doxygen, but with pre-PKG_OPTIONS variable

        Greg Troxel <>