Subject: pkg_add OS mismatch
To: None <>
From: Geert Hendrickx <>
List: tech-pkg
Date: 07/16/2005 19:14:58
I've always been told that OS version mismatches are not fatal for pkg_add,
but when I try this: 

> pkg_add zsh

It says:

> pkg_add: Package `' OS mismatch:
> pkg_add: NetBSD/i386 2.0 (pkg) vs. NetBSD/i386 2.0.2 (this host)
> pkg_add: install script returned error status
> pkg_add: 1 package addition failed

Even with -f, pkg_add gives the same error.  

Strangely enough, for some other packages, like links, it works fine.  

How can I install binary packages on my 2.0.2 system?