Subject: Re: x11/xextensions buildlink
To: Dieter Roelants <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 06/13/2005 09:27:24
On Mon, 2005-06-13 at 06:45 +0000, Dieter Roelants wrote:
> [ sorry for my slow response time ]
> On 06/07/05 23:15:54, Thomas Klausner wrote:
> > I wanted to ask: Why do you want the x11/xextension package
> > installed?
> Because I got an error from comositeext saying that I needed it.
> > > XFree86 Version 4.4.0
> > 
> > That version already comes with xextension, so pkgsrc should just
> > use the one coming with it. What is the error you get?
> Can't reproduce it now. In the meantime I found out that I didn't have  
> the xetc set installed. After that, everything builds fine. However  
> xextensions is still built as a dependency although it's only a build  
> time dependency. Is that wrong?

I commited a fix for xextensions two days ago or so, which solved the
build problems in compositeext.  However, it's not optimal, as it will
always force xextensions' installation.  I posted a better fix to the
list yesterday and will commit it soon.

Julio M. Merino Vidal <>
The NetBSD Project -