Subject: Re: SDL audio?
To: None <>
From: Richard Rauch <>
List: tech-pkg
Date: 06/10/2005 16:33:24
On Fri, Jun 10, 2005 at 10:43:20PM +0200, wrote:
> I don't use SDL myself but you'd try to install any of the
> audio/sdl-{arts,esound,nas} packages.


arts, I recall, had some problems (at least with my system); I had
to tell mplayer to build without arts support a long time ago and have
kept it that way.  (^&

Having added SDL-esound, bzflag can now find the esd interface.
But I don't get any sound out of bzflag.

I don't normally use esd.  Do I need to start it with any special
parameters to allow clients to connect to it?  esd does run, and
it does do its multi-tone beeping at startup, so it is able to find
my sound support.  And bzflag recognizes esd's presence...

Trying to build nasd ends with an error:

making all in common/netbsd...
cc -c -O2 -fno-strict-aliasing      -I/usr/X11R6/include    -DCSRG_BASED -D__AMD64__  -DFUNCPROTO=15 -DNARROWPROTO   -D__LANGUAGE_C__   -I/usr/wrkobj/net/nasd/work.socrates/nasd-1.3/include -DNETBSD  -I/include -I.    -DNASD_RPC_PACKAGE=2 -DNASD_CMU_PDL=0    nasd_netbsd_basic.c
nasd_netbsd_basic.c: In function `nasd_sys_init':
nasd_netbsd_basic.c:79: error: `nasd_ctimer_ticks' undeclared (first use in this function)
nasd_netbsd_basic.c:79: error: (Each undeclared identifier is reported only once
nasd_netbsd_basic.c:79: error: for each function it appears in.)
*** Error code 1

I can't connect to to update it at the moment.
("Connection timed out")  However, the files are all dated May 4...

  "I probably don't know what I'm talking about."