Subject: Re: Perl changes *after* branch
To: Johnny C. Lam <>
From: Jeroen Ruigrok/asmodai <>
List: tech-pkg
Date: 06/08/2005 11:26:27
-On [20050608 00:40], Johnny C. Lam ( wrote:
>I'm removing perl-5.6.x from pkgsrc *after* pkgsrc-2005Q2 is branched. 
>Any packages that rely on perl-5.6.x and don't work with perl>=5.8.x 
>will be marked as broken.  This is just a heads-up for any perl-5.6.x 
>users out there, and is a warning to start thinking about updating their 
>Perl installation.

People using more languages than English should have moved to 5.8.x long ago
anyway. ;)

>I also have more sophisticated changes in mind that I have not posted 
>yet to this list.  Again, this is just a heads-up for pkgsrc Perl users 
>to allow for planning when to update their Perl installation.

Have you looked at bsdpan which is included in the FreeBSD ports?  Very
useful for registering pkgs installed through the CPAN module. (Haven't had
the time yet to check if it already supported something like this in

Jeroen Ruigrok van der Werven <asmodai(at)> / asmodai / kita no mono
Free Tibet! |   |
To desire immortality is to desire the eternal perpetuation of a great