Subject: issues with building on solaris 9/sparc
To: None <>
From: nate <>
List: tech-pkg
Date: 05/29/2005 15:48:21
I think this may be related to libtool somehow as the
failures are the same accross the board, and only
seem to impact stuff that uses libtool.

system is Solaris 9, with all of the packages
that the docs say are required installed.

   PKGINST:  SUNWsprot
   VERSION:  5.9,REV=2001.
   VERSION:  11.9.0,REV=2002.
   PKGINST:  SUNWbtool
   VERSION:  11.9.0,REV=2002.
   VERSION:  11.9.0,REV=2002.
   VERSION:  5.9,REV=2001.12.10

SunOS 5.9 Generic_117171-07 sun4u sparc SUNW,Sun-Fire-V210

bootstrap worked fine, compiled gcc 2.95.3 fine,
but seems everything else I try to build(nmap, net-snmp)
sofar fails. snip from log:

libtool  --mode=link gcc -O -I/usr/pkg/include -I. -I. -rpath /usr/pkg/lib
-version-info  '0:1:0' -o maketables.lo get.lo study.lo pcre.lo
gcc -shared -Wl,-h -Wl, -o .libs/ 
.libs/maketables.o .libs/get.o .libs/study.o .libs/pcre.o 
-L/space/pkgsrc/devel/pcre/work/.buildlink/lib -lc
(cd .libs && rm -f && ln -s
(cd .libs && rm -f && ln -s
false cru .libs/libpcre.a  maketables.o get.o study.o pcre.o
*** Error code 1

the failures happen in the same place for all apps. If say
I try to compile pcre(above log taken from that) from
the raw distfile it compiles fine, no errors.

same with nmap.

I just tried to compile lynx and got the same error.

I installed fping fine, it doesn't appear to use libtool

log from the pcre build(both build output and work log)
is here:

I am new to pkgsrc, though I am used to getting more information
from a failed compile then just "Error code 1"

I tried setting PKG_DEVELOPER=1 in /etc/mk.conf but that didn't
give me any additional information.

been searchin google on this for a while and can't find any

downloaded the bootstrap tarball today and pkgsrc.tar.gz today
as well.

any ideas appreciated