Subject: library mismatch with gnutls and gnome-vfs2
To:, <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 05/17/2005 12:02:25
I was configuring wip/grip and it failed with:

/usr/bin/ld: warning:, needed by
/tmp/pkgsrc/wip/grip/work.montecristo/.buildlink/lib/, not
found (try using -rpath or -rpath-link)
undefined reference to `gnutls_compression_set_priority@GNUTLS_REL_1_0_9'

I have which is from package

That package depends on:


I have gnutls-1.2.3 installed which provides

I found in my old vulnerable/gnutls-1.0.20nb2.tbz package.
So I guess that gnome-vfs2 I am using was built using older gnutls.

On April 15, gnome-vfs2/ set
+BUILDLINK_RECOMMENDED.gnome-vfs2+=     gnome-vfs2>=2.10.0
(The update to 2.10.0 was done on March 22.)

And on May 2, gnutls/ set
+BUILDLINK_RECOMMENDED.gnutls+= gnutls>=1.2.3
(Update was done on same day.)

My packages were built May 7 (gnutls) and April 22 (gnome-vfs2). (Notice
how it allowed me to install older gnome-vfs2 built with newer gnutls.)

Does anyone see the same of the soname change for gnutls?

Our pkgsrc guide (section 10.2.2) says "In some cases, the packages that
depend on this new version may need their PKGREVISIONs increased and, if
they have files, their BUILDLINK_DEPENDS. pkg adjusted,

jmmv: may I do commit this for sysutils/gnome-vfs2/

-BUILDLINK_RECOMMENDED.gnome-vfs2+=     gnome-vfs2>=2.10.0
+BUILDLINK_RECOMMENDED.gnome-vfs2+=     gnome-vfs2>=2.10.1

This will force using a newer version of gnome-vfs2 which uses the new

Or should I just forget about it since this happened 15 days ago?

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links