Subject: Re: CVS commit: pkgsrc/www
To: Shin'ichiro TAYA <>
From: Jan Schaumann <>
List: tech-pkg
Date: 05/15/2005 13:32:25
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Jan Schaumann <> wrote:
> Thanks for the update.  I see you already requested pullups for
> pkgsrc-2005Q1, but I seem not to be able to build the new firefox nor
> the new mozilla-gtk2:
> ...
> checking for trouble comparing to zero near std::operator!=3D()... no
> checking for LC_MESSAGES... yes
> ./configure: /bin/pkg-config: not found
> *** Your version of pkg-config is too old. You need version 0.9.0 or
> newer.
> *** See
> configure: error: Library requirements (gtk+-2.0 >=3D 1.3.7) not met;
> consider adjusting the PKG_CONFIG_PATH environment variable if your
> libraries are in a nonstandard prefix so pkg-config can find them.
> *** Error code 1
> The problem appears to be that configure tries to run '/bin/pkg-config',
> instead of ${PREFIX}/bin/pkg-config.
> (Building mozilla (ie without -gtk2) works fine.)

Aah, pkgsrc-2005Q1 wants USE_BUILDLINK3=3DYES.  That needs to be added
before the pullup can be done.

I love how I find the problem to a solution right after sending an email
to ask about it.


Life," said Marvin, "don't talk to me about life."

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)