Subject: Re: CVS commit: pkgsrc/www
To: Shin'ichiro TAYA <>
From: Jan Schaumann <>
List: tech-pkg
Date: 05/15/2005 13:24:48
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Shin'ichiro TAYA <> wrote:
> Module Name:	pkgsrc
> Committed By:	taya
> Date:		Sat May 14 15:27:10 UTC 2005
> Modified Files:
> 	pkgsrc/www/firefox: Makefile Makefile-firefox.common PLIST
> distinfo
> 	pkgsrc/www/firefox-gtk1:
> Log Message:
> Update firefox & firefox-gtk1 to 1.0.4.
> This is a security fix release.
> Fixed vulnerabilities are follows:
> MFSA 2005-44  Privilege escalation via non-DOM property overrides
> MFSA 2005-43 "Wrapped" javascript: urls bypass security checks
> MFSA 2005-42 Code execution via javascript: IconURL

Thanks for the update.  I see you already requested pullups for
pkgsrc-2005Q1, but I seem not to be able to build the new firefox nor
the new mozilla-gtk2:

checking for trouble comparing to zero near std::operator!=3D()... no
checking for LC_MESSAGES... yes
=2E/configure: /bin/pkg-config: not found
*** Your version of pkg-config is too old. You need version 0.9.0 or
*** See
configure: error: Library requirements (gtk+-2.0 >=3D 1.3.7) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your
libraries are in a nonstandard prefix so pkg-config can find them.
*** Error code 1

The problem appears to be that configure tries to run '/bin/pkg-config',
instead of ${PREFIX}/bin/pkg-config.

(Building mozilla (ie without -gtk2) works fine.)

Any ideas?


"Drink up. The world's about to end."
"This must be Thursday. I never could get the hang of Thursdays."

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)