Subject: suse91_glx and x11 dependency
To: None <>
From: Bernd Ernesti <>
List: tech-pkg
Date: 05/15/2005 17:31:12

I think that suse91_glx needs to depend on suse91_x11.
Why? Because it installs files in emul/linux/usr/X11R6/lib/modules/dri
and you can't delete suse91_x11 without getting a complaint that it
couldn't delete all directories.

And the suse91_glx libraries depends on X11 libraries:

/usr/pkg/emul/linux/usr/lib# /emul/linux/usr/bin/ldd => /lib/ (0xbdb29000) => /usr/X11R6/lib/ (0xbdb24000) => /usr/X11R6/lib/ (0xbdb15000) => /usr/X11R6/lib/ (0xbda19000) => /lib/ (0xbda16000) => /lib/ (0xbd901000)
        /lib/ => /lib/ (0x00000000)