Subject: Re: ruby without X?
To: None <,>
From: Takahiro Kambe <>
List: tech-pkg
Date: 05/11/2005 07:20:01

In message <>
	on Tue, 10 May 2005 13:33:26 -0400,
	"David W. Talmage" <> wrote:
> Is it possible to move the X11-related packages out of lang/ruby1[68]?
lang/ruby1[68] are meta pacakges which contain ruby-tcltk/ruby-tk.
But lang/ruby1[68]-base pacakges should never depend on X11.

> Would anyone be inconvenienced if that happened?  Doing so would make
> it easier for me to install www/instiki on a server that hasn't any
> X11.  I do it now by commenting out the X11 dependencies but there has
> to be a better way.
How old is your pkgsrc tree?

% cd /usr/pkgsrc/www/instiki
% make print-build-depends-list
This package requires package(s) "ruby18-base-1.8.2nb1 ruby18-digest-1.8.2nb1 ruby18-zlib-1.8.2nb1" to build.
% make print-run-depends-list  
This package requires package(s) "ruby18-base>=1.8.1 ruby18-digest-[0-9]* ruby18-zlib-[0-9]*" to run.

Thus, www/instiki dosen't depend on X11.


Takahiro Kambe <>