Subject: PKGBASE missing in some packages? (make show-needs-update fails)
To: None <>
From: Lars Nordlund <>
List: tech-pkg
Date: 05/07/2005 15:06:05

Consider the following output that I currently have on my system:

===> lars@glengoyne:/usr/pkgsrc/chat/xchat2 %make show-needs-update
chat/xchat2 => (none) => needs install of xchat-2.4.1nb1
===> lars@glengoyne:/usr/pkgsrc/chat/xchat2 %pkg_info | grep xchat
xchat-2.4.1nb1      X11 (X Window System) IRC client, using the GTK2

That version of xchat I have installed is indeed from chat/xchat2.
Adding 'PKGBASE=xchat' in the Makefile.common fixes the problem. Also at
least mail/sylpheed-devel suffers from the same problem.

Best regards
	Lars Nordlund