Subject: update devel/prc-tools?
To: None <>
From: John D. Baker <>
List: tech-pkg
Date: 05/06/2005 14:26:08
For the longest time, devel/prc-tools has been marked BROKEN, with the
note that it does not build with gcc3 or buildlink3.

Might part of the issue be the age of distribution and supporting tools?
devel/prc-tools is based on:

    prc-tools-2.2  with:

Doing some research, the latest prc-tools and supporting tools are:

    prc-tools-2.3  with:
        gcc-2.95.3 (m68k)
        gcc-3.3.1 (arm)

I've just finished building it locally (outside of pkgsrc) on MacOS X
10.2.8 (gcc 3.3) and it built and installed just fine.  I only installed
for m68k-palmos and thus only gcc-2.95.3.  I did have to manually create
some of the directories it wanted since I was building as an unpriviledged
user.  I had to point it to /usr/pkg/bin/texi2html, since it declared
the one in the base system to be antiquated.

Perhaps devel/prc-tools could benefit from the update?

John D. Baker, KN5UKS                    NetBSD     Darwin/MacOS X
jdbaker(at)mylinuxisp(dot)com                 OpenBSD            FreeBSD
BSD -- It just sits there and _works_!