Subject: PHP + libxml2 issues
To: None <>
From: Dan Labute <Dan.Labute@Netcontech.Com>
List: tech-pkg
Date: 05/06/2005 15:33:57

	I am currently running NetBSD 2.0.2, and Apache 2.0.53 on the i386
platform. I was having difficulty getting the PHP5 package from pkgsrc
installed and configured correctly with Apache 2.x, so I downloaded and
built the php source code myself from the PHP website. With the majority of
./configure options that I've tried, the source compiles and installs

	The place I am running into difficulty is in trying to "make" php after I
do a ./configure with the following options:

./configure --with-apxs2=/usr/pkg/sbin/apxs --with-xml --with-pear --enable-
track-vars --enable-versioning --with-dom --with-regex --with-libxml-dir=/us

	The configure script executes correctly, but when I run make, it terminates
(eror code 1), with the following errors:

ext/dom/php_dom.lo(.text+0x40ab): In function `dom_objects_set_class':
/var/tmp/php-5.0.4/ext/dom/php_dom.c:907: undefined reference to
ext/simplexml/simplexml.lo(.text+0x120a): In function `sxe_properties_get':
/var/tmp/php-5.0.4/ext/simplexml/simplexml.c:685: undefined reference to
ext/simplexml/simplexml.lo(.text+0x2310): In function `php_sxe_object_new':
/var/tmp/php-5.0.4/ext/simplexml/simplexml.c:1206: undefined reference to
*** Error code 1

	Not sure why, but this occurs whenever i use the --with-libxml... option.
Are there any known incompatibilities between libxml2(from
pkgsrc)/php-5.0.4/NetBSD 2.0.2? Any workarounds?

Any help is greatly appreciated.

 Dan Labute

 Netcon Technologies Inc.
 Suite 135 - 4474 Blakie Road
 London, Ontario, Canada
 N6L 1G7
 Voice: +1.519.652.0401
 Fax: +1.519.652.9275