Subject: Re: Problem with ap-php-4.3.10.tgz package for i386/2.0
To: None <Scott.Burns@Netcontech.Com>
From: SUNAGAWA Keiki <>
List: tech-pkg
Date: 05/04/2005 14:27:14
From: "Scott R. Burns" <Scott.Burns@Netcontech.Com>
Subject: Problem with ap-php-4.3.10.tgz package for i386/2.0
Date: Wed, 4 May 2005 00:17:32 -0400

> a) Why this package is complaining about 2.0.2, when others on packages
> indicated for 2.0 did not ?

I have no clue here.  I downloaded and extracted expat and
ap-php binary packages.  both have a line OS_VERSIOIN=2.0.

> b) Is this even required for apache 2.0 machines or is it built in to the
> newer apache ?

apache 1.3.x is default in pkgsrc, so if you want to use
apache 2.x, you have to set PKG_APATCH_DEFAULT to apache2 in
/etc/mk.conf, then build your own.  Please look at
pkgsrc/mk/ for more detail.  You may want to make
binary packages of them.  pkgtools/pkg_tarup should help.
BTW php 4 in pkgsrc has been updated to 4.3.11.

> c) Is this something the developers even require to use PHP with Apache or
> is it only required in specific cases ?

I use apache13 only, but above should be enough.