Subject: Re: Still a challenge: pkgsrc on IRIX 6.5
To: Jan Schaumann <>
From: Timo Schoeler <>
List: tech-pkg
Date: 04/25/2005 21:30:01

to come up with this again (sorry, but i absolutely had no spare time 
to get into this in april :(...

on 25th march 2005 Jan Schaumann wrote:

> Timo Schoeler <> wrote:
>>>> a short note on my environment:
>>>> IRIX 6.5.25m and gcc, make, binutils etc. installed from
>>> I am note sure, but it might be that pkgsrc on IRIX is configured to
>>> assume
>>> MIPSpro cc.
>> but (as even jan schaumann said) it _should_ run with gcc.
> Right, if gcc is actually used.  But as you see below, you're actually
> invoking the MIPSPro compiler.

i reinstalled the machine from scratch a few days ago (6.5.27m) as i 
got a faster CPU in it (it now is a R12k/400 with 2MByte cache -- nice 
for pkgcomp i guess ;) and gave it another try:

* installed IRIX 6.5.27m from scratch

* installed patches and cvs, gcc

* just out of curiosity built OpenSSL 0.9.7f (IIRC) and OpenSSH 4 as 
well as GnuPG 1.4.0 -- it just worked (TM)!

* checked out pkgsrc and bootstrapped it (it worked as always up til 
this point)

* tried to build sth from pkgsrc -- now it *loops*. yes, it loops. i'll 
provide an example of this tomorrow or so.

however, now going to the main point of my email:

i'd really like to contribute to the IRIX side of pkgsrc, but to do so 
i have to be able to run it...

is there any volunteer to have a peek on my machine? the machine is 
accessable from the net when it's up and running...

i'll provide account information -- please (privately) mail me. tia!

>>>> -L/usr/pkg/lib) works... no
>>>> configure: error: installation or configuration problem: C compiler
>>>> cannot create executables.
>>>> *** Error code 1
>>> what does config.log say?
>> [*] /usr/pkgsrc/devel/patch/work/.wrapper/bin/cc -o conftest -O2
> That's not config.log -- that's the work log.  config.log is in the
> extracted work dir, where the configure script itself is in.  But 
> either
> way, this log also tells you exactly what command is invoked:
>> <.> /usr/bin/cc -o conftest -O2 -Wl,-R/usr/pkg/lib -L/usr/pkg/lib
>> conftest.c -mabi=n32
> /usr/bin/cc is quite unlikely to be gcc, and much more likely to be the
> MIPSPro compiler.  As such, it will not accept the '-mabi=n32' flag,
> since that's a GCC flag.
>> jan schaumann said that isn't understood by gcc. i'll receive my
>> MIPSPro licenses in a few days, but i'd like to be able to use gcc,
>> too.
> You should be able to use gcc by setting
> in /etc/mk.conf explicitly.
> The confusion here comes from the fact that PKGSRC_COMPILER is not set
> at all, so gcc is assumed, but at the same time the proper path is not
> set and 'cc' is found to be /usr/bin/cc, which is the MIPSPro compiler.
> -Jan
> P.S.: Let's move this discussion to tech-pkg@, please.
> -- 
> Information wants to be free.
Timo Schoeler | |
//macfinity -- finest IT services |
Key fingerprint = F844 51BE C22C F6BD 1196  90B2 EF68 C851 6E12 2D8A

There are 10 types of people in the world. Those who understand binary 
and those who don't.