Subject: Re: gimp2 on NetBSD 2.0?
To: Christoph Badura <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/22/2005 09:08:33
On Fri, 22 Apr 2005, Christoph Badura wrote:

> I've build gimp-2.2.4 around March 25th from then current pkgsrc and
> it refuses to start complaining that:
> 	The Fontconfig version being used is too old!

> And, of course, it is right.  I have /usr/X11R6/lib/
> from the fontconfig-1.0.2 of 2.0's xsrc and /usr/pkg/lib/
> from pkgsrc's fontconfig-2.3.0 on the system.
> Or has that been fixed in the mean time?

I think that problem was fixed in mk/ revision 1.8 on April
9 by markd:

  Sense of a USE_BUILDLINK3 test was reversed when USE_BUILDLINK3 was
  switched on always, resulting in instances of X11R6/lib libraries being
  linked in to binaries along with pkgsrc versions of the same. Fix.

The problem was introduced on March 24, a few days before you built
your package. Can you try rebuilding it again (with an up-to-date pkgsrc)?

 Jeremy C. Reed

 	  	 	 Media Relations and Publishing Services