Subject: Re: Netatalk 2.0.2 configure looking for DB library version in vain
To: Daniel R. Killoran,Ph.D. <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/07/2005 13:23:16
On Thu, 7 Apr 2005, Daniel R. Killoran,Ph.D. wrote:

> Ok, I did this (after deleting pkgsrc in its entirety, to avoid
> conflicts), and again attempted to build netatalk from scratch.
> It ran for two days, mostly building dependencies, and then stopped
> thus:

> ===> Installing for db4-4.3.27nb1
> ===> db4-4.0.14 is already installed - perhaps an older version?
> *** If so, you may use either of:
> ***  - "pkg_delete db4-4.0.14" and "/usr/bin/make reinstall" to upgrade

This means that db4-4.0.14 is currently installed.

You said you deleted pkgsrc in its entirety. Somehow your db4 package was
not deleted. Or you updated your pkgsrc collection during your builds so
it first built (and installed) old db4-4.0.14 and then since it saw it
needed newer db4 it built it again.

Do a "pkg_delete db4-4.0.14". This shouldn't hurt anything if you really
deleted pkgsrc in its entirety.

And then continue your pkgsrc/net/netatalk build.

Good luck,

 Jeremy C. Reed

 	  	 	 open source, Unix, *BSD, Linux training