Subject: kdebase3 needs imake ... and /usr/X11R6/bin/imake: No such file or
To:, <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 04/07/2005 09:40:47
The configure of kdebase3 failed due to missing imake. (Two different
configure scripts check for it. kdelibs3 doesn't need imake -- I didn't
have it installed to build kdelibs3.)

So I added:

USE_IMAKE=              YES # uses imake to retrieve various X settings

I had xorg-libs installed already.

So then I installed xorg-imake.

Then the build of kdebase3 (after clean) installed xpkgwedge too.

Then the configure for kdebase3 failed with:

imake -v -DUseInstalled -I/usr/lib/X11/config -I/usr/X11R6/lib/X11/config
/usr/X11R6/bin/imake: No such file or directory
/usr/X11R6/bin/imake: No description file.

So I found a PR about similar:

#26505: x11/xorg-imake: buildlink path is embedded into xmkmf

I am not sure what to look for.

I have a work/.wrapper/bin/imake. I don't see any wrapper for xmkmf or
pkgxmkmf. (But both are in the PATH as in the wrapper.)

I don't see any problem paths in xmkmf or pkgxmkmf.

Google tells me I have had similar issue:
But I am not sure now.

I am using X11_TYPE=xorg and X11ROOT_PREFIX=X11R6 which has worked fine on
some other systems. But when I run it manually on the system that
previously worked fine to build kde and many packages I get:

$ imake -v -DUseInstalled -I/usr/lib/X11/config
imake: No such file or directory
imake: No description file.

(Which I believe is because is missing Imakefile.)

Any one have any ideas on how I can troubleshoot this with kdebase3?

Anyways, my workaround was to get rid of that

And then make sure imake is in my PATH and then the configures complete

When I have USE_IMAKE=NO and imake is not in my path, I receive the error
in config.log:

configure:46051: checking for xmkmf
configure:46107: result: /usr/X11R6/bin/xmkmf
configure:46114: checking X paths
imake -DUseInstalled -I/usr/X11R6/lib/X11/config
Imakefile.c:35: Imake.tmpl: No such file or directory
imake: Exit code 1.
configure:46135: result: failed
configure:46139: error: /usr/X11R6/bin/xmkmf (imake) failed.
Make sure you have all necessary X development packages installed.
On some systems a missing /lib/cpp symlink is at fault.

I tried without and with the /lib/cpp symlink.

And /usr/X11R6/lib/X11/config/Imake.tmpl does exist.

 Jeremy C. Reed

 	  	 	 technical support & remote administration