Subject: www/lynx zh_TW.po gettext issue revisited, this time on Linux
To: None <>
From: Georg Schwarz <>
List: tech-pkg
Date: 04/04/2005 23:13:38
I've installed from scratch the current pkgsrc.tar.gz on a Debian 3.0
Linux system.
Interestingly it seems that, unlike on Debian unstable, pkgsrc gettext
does not get installed, and thus we won't run into the libiconv issue
experienced on Debian unstable (but I'll investigate that more closely

One negative effect of this is that when building lynx it breaks with a
buch of the following error messages:
zh_TW.po:706: invalid control sequence
I had come across that in March of 2004 on IRIX, and the result back
then what that zh_TW.po was not fit for the (then) current gettext-lib.
(cf. ). It
was adapted, but this apparently results in it breaking on older gettext
versions as the one shipped with Debian 3.0:

schwarz@sendai:~/pkgsrc/www/lynx$ gettext --version
gettext (GNU gettext) 0.10.40

Any suggestions what to do about this?
In the mean time, can I found pkgsrc to use its own gettext?

Georg Schwarz     +49 178 8545053