Subject: Re: Netatalk 2.0.2 configure looking for DB library version in vain
To: Louis Guillaume <>
From: Daniel R. Killoran,Ph.D. <>
List: tech-pkg
Date: 04/04/2005 09:03:01
> On Mar 31, 2005, at 5:18 PM, Louis Guillaume wrote:
>> It's not really clear yet how far you got using pkgsrc, and what 
>> exactly you tried before, so I'll try to explain the way I would do 
>> it.
>> Read through to the end first, because I've put some ideas for 
>> building binary packages further down that you'd have to do first...
>> 1. Get the latest pkgsrc...
>> $ cd /usr
>> $ export
>> $ cvs login
>>   < type "anoncvs" for the password >
>> $ cvs checkout -r pkgsrc-2005Q1 -P pkgsrc
>>   < will take a while >
>> ... Now you will have the latest stable pkgsrc in /usr/pkgsrc

Ok, I just tried this (after a delay caused by trying to build ethereal 
- more on that later) and got:

MacIIvx# cd /usr
MacIIvx# export
export: Command not found.    (oops! forgot I am using csh!)
MacIIvx# set
MacIIvx# cvs login
cvs login: No CVSROOT specified!  Please use the `-d' option
cvs [login aborted]: or set the CVSROOT environment variable.
MacIIvx# echo $CVSROOT
MacIIvx# cvs -d login
Logging in to
CVS password:   (here I typed "anoncvs")
cvs login: warning: failed to open /root/.cvspass for reading: No such 
file or directory

What did I screw up?

Dan Killoran