Subject: Re: gdal, openscenegraph
To: Alistair Crooks <>
From: David Price <>
List: tech-pkg
Date: 03/31/2005 13:58:35
The gdal-lib, gdal-docs, gdal and geos packages should be ok now.
Wip/geos2 dependancies have been changed to wip/geos, and that package
installs geos-2.0.0.

Apologies for the confusion,

>>> I believe that the gdal package originated from our work so I'm glad
>>> it is of use.  However, we have recently split it into several
>>> (gdal-lib, gdal-docs, and gdal (a metapackage)) so as to isolate the
>>> dependencies on doxygen, teTeX, ... .
>> Ah, that's nice.
>>> If you could send me the updates you made to the gdal package we can
>>> try to fold them into our new set.  Or are those already committed in
>>> wip?
>> I don't know - I don't think there were many modifications.  If you want
>> to check the differences between wip and my package, just download my
>> files from the URL in the previous mail and diff it against pkgsrc-wip.
> The gdal package in pkgsrc-wip depends on wip/geos2 which I couldn't
> see anywhere.
> I also did a gdal package some time ago, but didn't bother splitting
> into docs and lib sub-packages, so yours is nicer.  I also did a grass
> package (and remember having to make shedloads of patches for non-root
> builds, but that's rather tangential to the gdal packages).
> Regards,
> Alistair