Subject: Re: pkgsrc subversion upgrade problems?
To: Urban Boquist <>
From: Eric Gillespie <>
List: tech-pkg
Date: 03/24/2005 14:30:32
Urban Boquist <> writes:

> lan-gw$ svnlook info svn.old
> svn: Berkeley DB error while opening environment for filesystem svn.old/db:
> DB_VERSION_MISMATCH: Database environment version mismatch
> svn: bdb: Program version 4.3 doesn't match environment version
> lan-gw$ svnlook info svn 

Your repository is an older BDB, most likely 4.2.  Build against
the same BDB version your repository is, svnadmin dump it,
upgrade BDB to 4.3, and then svnadmin load it.

Alternatively, just dump with the old BDB and then load into a
new FSFS repository.  This BDB compatibility pain is one of many
reasons FSFS is the default in pkgsrc (and everywhere, starting
with the upcoming Subversion 1.2).

Eric Gillespie <*>