Subject: Re: aalib and libcaca support for MPlayer?
To: Leonard Schmidt <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 03/15/2005 23:37:34
On Tue, 2005-03-15 at 22:47 +0000, Leonard Schmidt wrote:
> Hello,
> is there a reason why mplayer isn't built with support for aa and
> libcaca even though these two are in pkgsrc?
> I'm successfully using the following:
> I created the Makefile.diff file for libcaca because I wanted to use it
> with X11 support. 
> But as far as I understood jmmv and the pkgsrc system, a separate package, 
> for example libcaca-x11, would be better, I guess.

Yep, I think it'd be good in this case (libcaca), just as we have aalib
and aalib-x11.

As for mplayer, it keeps getting fatter with every dependency.  It'd be
nice to have a method to build it with whichever is wanted (similar to
the existent MPLAYER_DISABLE_PLUGINS), and keep a reasonable set of
default dependencies.  FWIW, there is a document somewhere detailing how
mplayer should be package; I guess it might be of some help.

Julio M. Merino Vidal <>
The NetBSD Project -