Subject: renaming suggestion for _PKG_SILENT and _PKG_DEBUG
To: None <>
From: Roland Illig <>
List: tech-pkg
Date: 03/11/2005 20:54:10
Hi all,

I'd like to have a public Makefile variable (that is: not starting with 
an underscore) that has the value ${_PKG_SILENT}${_PKG_DEBUG}.

That variable can then be used in packages or helper files, knowing that 
it is part of the pkgsrc interface, and not just an implementation detail.

I don't know a good name for it yet, but I really want to have this 
variable. Perhaps PKG_CMD could be an appropriate name for it, provided 
we will never have a tool with that same name.