Subject: Re: www/gtkhtml3: dependency for libsoup
To: Kouichirou Hiratsuka <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 03/11/2005 18:55:32
On Sat, 2005-03-12 at 00:13 +0900, Kouichirou Hiratsuka wrote:
> Hello,
> In www/gtkhtml3, libsoup versions are different between Makefile
> and  Which is correct?
> % cd /usr/pkgsrc/www/gtkhtml3
> % grep libsoup *
> Makefile:.include "../../net/libsoup-devel/"
> "../../net/libsoup/"

libsoup-devel is the correct one; otherwise the package couldn't
be built.

BTW, libsoup-devel's name is messy.  It should be renamed, but I'm not
sure which could be the right name.  I'm more inclined to libsoup2.2
(rather than libsoup22, which makes little sense), and then change
libsoup to libsoup1.99 (as libsoup199 could look even worse).
The problem is that there is no prior art in pkgsrc for such names...

Any suggestions?  I hope we can do this during the freeze.


Julio M. Merino Vidal <>
The NetBSD Project -