Subject: Re: libiconv breaks on Debian 3.1
To: Jeremy C. Reed <>
From: Marc Recht <>
List: tech-pkg
Date: 03/06/2005 20:48:49
>> I am just building along pkgsrc on a newly installed Debian 3.1 (i386)
>> system. I end up like this:
>> Oops, what is going wrong here?
> I purposely used PKG_FAIL_REASON instead of PKG_SKIP_REASON to find out
> what is forcing libiconv.

I've exactly the problem on all Linux system I administrate, but I 
hadn't had the time to actually trace it down...

> gettext needs gettext-lib which requires libiconv.
> I also don't use gettext-lib because it is not needed under Linux.

I personally prefer to use absolutly nothing from the Linux system. 
(And thus I've set PREFER_PKGSRC=yes on all these systems.)