Subject: Re: lang/gcc3-c++ is still broken on Solaris
To: grant beattie <>
From: None <>
List: tech-pkg
Date: 02/11/2005 00:36:38
grant beattie wrote:
> On Wed, Feb 09, 2005 at 10:56:33PM +0000, wrote:
>># uname -a
>>SunOS usparc 5.10 s10_72 sun4u sparc SUNW,Ultra-5_10
>>Greetings, has anyone ever managed to build lang/gcc3-c++ on Solaris? 
>>I've noticed it has been broken for a long time now and I'm not a pkgsrc 
>>guru, so I don't know how to fix it. The problem is: half way through 
>>building gcc3-c++, it seems that configure script goes into infinite 
>>loop and keeps running the same tests over and over again.
>>I would really appreciate any suggestions on how to resolve this issue, 
>>as it would be extremely nice to have GNU C++ compiler on Solaris via 
> I recently built gcc3-c++ on Solaris 9 with an external gcc without
> any problems:
> # pkg_info | grep gcc
> gcc3-c-3.3.4        GNU Compiler Collection, v3 - C compiler
> gcc3-c++-3.3.4      GNU Compiler Collection, v3 - C++ compiler
> gcc3-f77-3.3.4      GNU Compiler Collection, v3 - F77 compiler
> # pkg_info -B gcc3-c++ | grep -i CC_VERSION
> CC_VERSION=gcc-3.3.4
> I have previously built it using SunPro without any problems, too. I
> don't know if this is specific to Solaris 10 -- it may be.
> could you send-pr(1) this, and include the build output fragment that
> loops?
> grant.

OK, I'll file a PR. I've tried lang/gcc34 and it compiles C and C++ 
compilers OK, but I have the following problem on Solaris:

I used external gcc to build lang/gcc34, however dependant packages like 
zlib, libiconv, etc., and even gcc executable itself have references to 
external gcc's library. This will break those packages 
when I remove the external compiler. Is there any trick to fix this 
chicken-vs-egg problem?
I've tried rebuilding, for example zlib, with newly installed gcc34, by 
setting GCC_REQD=3.4 and running 'bmake clean', 'bmake replace'. For 
some reason zlib was still refering to external library.