Subject: minimum fortran or g77 required?
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 02/09/2005 17:55:59
I went to install math/fftw which has:
USE_LANGUAGES=          fortran

I have gcc3-f77-3.3.3nb1 installed. I have /usr/gcc3/bin/g77:
GNU Fortran (GCC) 3.3.3

Make in math/fftw started to retrieve gcc-3.3.5.tar.bz2.

mk/compiler/ has:
_GCC_DEPENDENCY+=       gcc3-f77>=${_GCC_REQD}:../../lang/gcc3-f77

Maybe we should have a _GCC_F77_REQD? Or do we really need something
better than 3.3.3?

I made it use my old fortran. It appeared to work fine.

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links