Subject: Re: xorg-server+any linux distribution
To: Juan RP <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 02/09/2005 18:39:59
On Wed, 2005-02-09 at 18:25 +0100, Juan RP wrote:
> Hi, I want to fix PR pkg/29212... but before I want to know comments
> about people who have installed xorg-server on a GNU/Linux distribution,
> for example:
> 	* Do you have man/man4/foo.4x or foo.4?
> 	  (Same with the sections 5 and 7).

WRT the manual pages... couldn't we force _all_ systems to use the
_same_ extensions?

To me, the current situation is very difficult to maintain and _very_
error prone (as seen by the amount of prs filled against xorg's/xfree's
plist files).

> 	* The name of your Linux distribution you're using.

The same goes with this.  I guess these files should never be installed.
After all, we should enforce rc.subr usage in pkgsrc, and not "unknown"
scripts popping up from unknown places.


Julio M. Merino Vidal <>
The NetBSD Project -