Subject: perl update for security vulnerability
To: None <>
From: Johnny Lam <>
List: tech-pkg
Date: 02/02/2005 16:06:41
I've updated the lang/perl58 packages in pkgsrc to 5.8.6nb3, which fixes 
CAN-2005-0155 and CAN-2005-0156.  They are "local root exploit" and 
"buffer overrun" security advisories, respectively.  The vulnerable 
versions are perl versions between 5.8.0 and 5.8.6nb2.

I'll be submitting patches for pkgsrc-2004Q4 soon to update lang/perl58 
on that branch to 5.8.5nb8 to fix this same issue.


	-- Johnny Lam <>