Subject: Re: Problems building "emacs" under NetBSD 2.0
To: None <,>
From: Johan A.van Zanten <>
List: tech-pkg
Date: 01/19/2005 01:48:36 (Matthias Scheler) wrote:
> In article <>,
> 	Matthias Scheler <> writes:
> > I cannot build "emacs" from "pkgsrc" (2004-12-29 HEAD sources) under
> > NetBSD 2.0 on my SPARCStation LX any more. It dies while trying to dump:
> [...]
> The problem is fortunately fixed in the 3.7.1nb2 version of the
> "tiff" package.
> > It looks like it dies loading "". But I have no idea why.
> > The build worked fine on both of my NetBSD-i386 systems.
> If I understood correctly "libtiff" had C++ support by default which
> caused this. The "libtiff" package now provides a ""
> for that purpose.

I found a different problem when trying to build editors/emacs for NetBSD 2.0
(release) on sparc, from an up-to-date /usr/pkgsrc:

This was the last line in
/local/NetBSD/pkg-build/editors/emacs/work.sparc/.work.log :

<.> /local/NetBSD/pkg-build/editors/emacs/work.sparc/.gcc/bin/gcc -nostartfiles -Wl,-rpath, -Wl,-rpath,/usr/pkg/lib -L/local/NetBSD/pkg-build/editors/emacs/work.sparc/.buildlink/lib -Wl,-z,nocombreloc -L/local/NetBSD/pkg-build/editors/emacs/work.sparc/.x11-buildlink/lib -Wl,-R//usr/X11R6/lib -Wl,-R/usr/pkg/lib -o temacs pre-crt0.o /usr/lib/crt0.o /usr/lib/crti.o /usr/lib/crtbegin.o dispnew.o frame.o scroll.o xdisp.o xmenu.o window.o charset.o coding.o category.o ccl.o cm.o term.o xfaces.o xterm.o xfns.o xselect.o xrdb.o fontset.o emacs.o keyboard.o macros.o keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o minibuf.o fileio.o dired.o filemode.o cmds.o casetab.o casefiddle.o indent.o search.o regex.o undo.o alloc.o data.o doc.o editfns.o callint.o eval.o floatfns.o fns.o print.o lread.o abbrev.o syntax.o unexelf.o mocklisp.o bytecode.o process.o callproc.o region-cache.o sound.o atimer.o doprnt.o strftime.o intervals.o textprop.o composite.o md5.o tparam.o lastfile.o gmal
 loc.o ralloc.o vm-limit.o widget.o mktime.o ../lwlib/liblw.a -L-lXaw /usr/lib/crtend.o /usr/lib/crtn.o -I/local/NetBSD/pkg-build/editors/emacs/work.sparc/.buildlink/include -lXmu -lXt -lSM -lICE -lXext -ltiff -ljpeg -lpng -lz -lm -lungif -lX11 -lossaudio -ltermcap -lm -lgcc -lc -lgcc

Please note that the above that begins with "<.>" and ending with "-lgcc"
is one line.  It may wrap somewhere between here and there, but it was
originally one line.

The problem is this, near the end:


 On the screen, during the build, this appears as:

-L -lXaw

 But it's not that way in the file.

 The errors i was getting are symbols in /usr/X11R6/lib/libXaw.a, and it
 was not finding them due to the botched line.

 When i removed the "-L", the repaired command worked fine, when run from
 this directory: