Subject: Re: upgrading ocaml
To: None <>
From: Antoine Reilles <>
List: tech-pkg
Date: 01/12/2005 22:55:54
Hash: SHA1


I worked a little on the packages involving ocaml.
There are few, and as you expected, they rely a lot on the ocaml 

I list here the package i worked on, and the url to get the package. To 
test it, just replace the old one.
First, i updated the ocaml package, reusing some of the patches for 
configure. It works well for me, but it needs testing on other 
platforms, like darwin. I will try to do this on darwin as soon as 

OK ./lang/ocaml/Makefile.common

Some package required update to work smoothly. I reused mainly the old 
NB: for mldonkey, i use a tgz provided by mww from darwinports, as the 
mldonkey project provides olny very old tgz, which require ocaml-3.07, 
and for unison and unison-devel, i use the same patches as in 
darwinports to get them compiling with ocaml-3.08.
OK ./converters/bibtex2html/Makefile
OK ./databases/geneweb/Makefile
OK ./x11/ocaml-graphics/Makefile
OK ./net/unison-devel/Makefile
OK ./net/unison/Makefile
OK ./net/mldonkey/Makefile.common
OK ./graphics/camlimages/Makefile
OK ./print/advi/Makefile

Those ports compile fine with the new ocaml without requesting any 
OK ./math/scilab/Makefile
OK ./textproc/hevea/Makefile
OK ./www/swiftsurf/Makefile
OK ./x11/lablgtk/Makefile
OK ./x11/lablgtk2/Makefile
OK ./x11/labltk/Makefile

Those ports are listed by 'find /usr/pkgsrc -name "Makefile*" | xargs 
grep ocaml" but dont use the ocaml port, so they should work finely.
X ./devel/swig-build/Makefile
X ./devel/swig-build/Makefile.common
X ./editors/xemacs-packages/Makefile
X ./lang/caml-light/Makefile

I have not updated the coq port as far, but since it was my main 
objective for upgrading ocaml to 3.08, i will work on it soon.
KO ./lang/coq/Makefile
     to update

Please, let me know if those updates work for you, if this work is 
useful, or if i should stop right now and wait for someone smarter to 
do it.


On Jan 12, 2005, at 14:44, Adrian Portelli wrote:

> To tell you the truth I wouldn't mind upgrading it as well.  There's a 
> package I've been meaning to import for a while but haven't been able 
> to because ocaml was too old.  I played round with a few updated 
> versions locally but since then other things got in the way and I'm 
> not that familiar with ocaml :)
> I think one thing we have to make sure of is that we don't break other 
> apps that depend on ocaml.  As you have noted, and I've found myself, 
> the packages that need ocaml can be very specific about which versions 
> of ocaml they choose to work with.
> Thanks for the package, I'll download it and see how it goes.  We 
> should  also test all other apps that need ocaml (I don't think there 
> are that many . . . say < 10 last time I looked).
> (I can also probably get access to a OS X box to test it on as well)
> Please feel free to email me off line if you've had success with other 
> packages and the new compiler and we can take it from there.
> regards,
> adrian.
> Antoine Reilles wrote:
>> Hash: SHA1
>> On Jan 11, 2005, at 23:27, Antoine Reilles wrote:
>>> Hi all,
>>> I tried to update the ocaml package to the latest version: 3.08.2
>>> I had to add USE_X11= yes
>>> The way X11 support was disables before is no more acessible
>> I tried to update the bibtex2html package to 1.74, since it requires 
>> a recent ocaml.
>> the update propositions are at:
>> For testing purposes, i used a tests directory for these package, 
>> instead of lang and textproc.
>> So i've modified the lines
>> DISTINFO_FILE=          ${.CURDIR}/../../tests/ocaml/distinfo
>> PATCHDIR=               ${.CURDIR}/../../tests/ocaml/patches
>> in ocaml/Makefile.common (with ../../tests/ instead of ../../lang/)
>> and
>> BUILD_DEPENDS=  ocaml-[0-9]*:../../tests/ocaml
>> in bibtex2html/Makefile (again, with ../../tests/ instead of 
>> ../../lang/)
>> Thanks for feedback,
>>   Antoine
>> Version: GnuPG v1.2.4 (Darwin)
>> iD8DBQFB5SIY4VqmoGDE/mwRAoSQAJ4ztLAyLDKABc0/dNgIakEgAserngCeMkKz
>> cAzze4sza1+pf86h1MuU6Pg=
>> =CCKZ
>> -----END PGP SIGNATURE-----
Version: GnuPG v1.2.4 (Darwin)