Subject: Re: problems building galeon12
To: Simon Burge <>
From: Steven M. Bellovin <>
List: tech-pkg
Date: 01/12/2005 11:01:29
In message <>, Simon Burge 
>"Steven M. Bellovin" wrote:
>> With up-to-date pkgsrc:
>> [ galeon12 lossage ]
>I can unfortunately confirm I see the same lossage with up-to-date
>pkgsrc on a 2.0 i386 box.  It looks like some mozilla API changed yet
>again, and galeon12 isn't dealing with it.  My current working galeon
>(from November 18 last year) is using mozilla-1.7.3nb2 as compared to
>mozilla-1.7.5 in up-to-date pkgsrc.
>Given that the galeon folks have said they're not maintaining the 1.2
>stream any more, it may be time to look for another browser.  I can't
>understand how they think that galeon 1.3 is an improvement :-/

I'll say.  (And part of the problem is that to use 1.3 well, you have 
to buy into a lot more gnomish stuff, like the program that maps 
extensions to handlers.  (It would be *really* nice if the gnome folks 
and the kde folks could agree on a protocol and database for that info, 
since one of the machines I maintain uses galeon instead of konqueror 
under kde.)
>Maybe another option is to keep a mozilla173 package around for galeon12
>to depend on, but I don't know how maintainable that would be.  Is this
>something that pkgviews can help with?

That would be very nice, though as other things change out from under 
it it may prove difficult to maintain.

Sigh -- I'm starting to play with Firefox with the prefbar extension.  
It's not as nice as Galeon, but gets me much of what I need.

		--Prof. Steven M. Bellovin,