Subject: Re: Compilation problem with pkgsrc/lang/perl58
To: Min Sik Kim <>
From: Curt Sampson <>
List: tech-pkg
Date: 01/05/2005 19:25:02
On Tue, 4 Jan 2005, Min Sik Kim wrote:

> Fixed.  Try with perl58/Makefile 1.71.

Well, now I'm getting:

          CCCMD =  cc -DPERL_CORE -c -fno-strict-aliasing -pipe -I/usr/pkg/include -O2 -pthread -I/usr/include  -Wall
LD_LIBRARY_PATH=/u/netbsd/pkgsrc/lang/perl58/work.i386/perl-5.8.6 cc -Wl,-R/usr/pkg/lib  -pthread  -L/usr/pkg/lib -o miniperl  miniperlmain.o opmini.o -L. -lperl -lm -lcrypt -lpthread
./ undefined reference to `gethostent'
*** Error code 1

make: stopped in /u/netbsd/pkgsrc/lang/perl58/work.i386/perl-5.8.6
*** Error code 1

This is under NetBSD 2.0. Anybody got a fix?

Curt Sampson  <>   +81 90 7737 2974
     Make up enjoying your city life...produced by BIC CAMERA