Subject: Re: problems with choosing a Berkeley DB
To: Johnny C. Lam <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 01/05/2005 15:39:23
On Wed, 5 Jan 2005, Johnny C. Lam wrote:

> 1. If a package required a db-1.85 interface, then the package should
>    mark itself as either USE_DB185=yes, or list the "db1" in BDB_ACCEPTED.

> [*] I say "-ldb1" but on NetBSD, this is simply the db-1.85 interface in
>     libc.  I may be importing a db1 package at some point in the future.

That would be great if you could import a db1 package. If not, I will
package db1.

I see that following the latest db4 will be continuing upgrades, but
a db1 (I assume) would never change.

Also is there way to choose which db is used by specific package via

In particular, I want to force my PAM and pkg_install to depend
on db1 instead of db4. (Or maybe I just set USE_DB185=yes or list the
"db1" in BDB_ACCEPTED?)

(For some reason, I thought I needed it for a lot more, but I think my old
packages accidently were depending on a db but didn't really need it.)

 Jeremy C. Reed

 	  	 	 technical support & remote administration