Subject: Re: abiword and solaris and popt
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 12/16/2004 13:55:41
On Tue, 14 Dec 2004, Jeremy C. Reed wrote:

> On Tue, 14 Dec 2004, Juan RP wrote:
> > Have you tried adding the popt dependency and specifying it to the configure
> > args?
> >
> > Maybe we should add explicitly this dependency...
> I am trying that, but then I get same error I saw before about needing GNU
> gettext.

Back to abiword. I notice that my old abiword package abiword-2.0.5 under
Linux did depend on "popt>=1.7nb3". A more recent abiword-2.0.11 under
NetBSD did not depend on popt. I see that the revision 1.80 of the
Makefile removed:
-CONFIGURE_ARGS+=       --with-popt=${BUILDLINK_PREFIX.popt}
-.include "../../devel/popt/"

May I add the

.include "../../devel/popt/"

back and bump the PKGREVISION? (I'll put in the Makefile and not the

It fixes one part of the Solaris build and also we probably should
use the package popt instead of popt included in the source. The
abi/doc/build/BUILD.TXT suggests that the popt provided with the system is
good enough.

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links