Subject: package compile using 'native' gcc under OSX/Darwin?
To: None <>
From: Malcolm Herbert <>
List: tech-pkg
Date: 12/03/2004 18:22:24
I've recently installed the pkgsrc bootstrap kit and so forth for my
shiny new PowerBook, however I don't seem to be able to convince the
build environment to use the gcc which is installed already on the
machine (it's running OSX 10.3.6, so has the devel kit pre-installed).

pkgsrc seems to want to download gcc for Darwin (which gives an error to
say that it doesn't exist) and won't proceed further ...

what can I do to remove the dependancy for gcc-* and use the one in
/usr/libexec/gcc? should I simply set CC=/usr/libexec/gcc in mk.conf or
in my environment somewhere?

Under NetBSD proper this was of course done for me ... under Darwin I
have no idea ... :)

Malcolm Herbert                                    System Administrator
ph [990] 54881 rm 28-241                          School of GeoSciences