Subject: Re: 143 - ___unvis13 redefinition
To: John Nemeth <>
From: grant beattie <>
List: tech-pkg
Date: 12/03/2004 11:10:23
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Nov 28, 2004 at 03:54:22PM -0800, John Nemeth wrote:

>      I'm trying to upgrade pkgsrc on my laptop which is running 1.4.3.
> I haven't upgraded the laptop because it only had 8 MB of RAM and could
> not reliably run the install, not to mention that it took days to
> compile a stripped down kernel.  I now have 20 MB of RAM, the maximum
> for my laptop, so I may try again some time.
>      Anyways, I downloaded a current pkgsrc tarball, unpacked it, went
> to /usr/pkgsrc/pkgtools/pkg_install, and tried to make install.  This
> bombed miserably due to the use of makefile features not supported by
> older versions of make.  So, I went to /usr/pkgsrc/bootstrap and tried
> ./bootstrap.  This bombed with:
>      /tmp/cczolCwz.s: Assembler messages:
>      /tmp/cczolCwz.s:36: Fatal error: Symbol ___unvis13 already defined.

I'm not much of a toolchain person, and it's not exactly clear to me
what is happening here, but I have added a workaround which allows
bootstrap to build on NetBSD 1.4.3 (tested in a chroot on -current).


Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (NetBSD)