Subject: net/napshare
To: None <>
From: Greg Troutman <>
List: tech-pkg
Date: 12/02/2004 16:58:31
I'm not sure why this package has not been upgraded--I simply changed
the version number in the pkgsrc/net/napshare/Makefile to install the
latest version (v1.3) and it installed and runs fine.  The reason an
upgrade matters is that the version in pkgsrc (v1.1) is pretty much
broken/useless anymore. It has the webcache servers embedded in the
binary, and they are no longer valid servers, so anyone trying to
install the package will get a napshare that sits and forever tries
and fails to connect to the gnutella network, and other than patching
the binary I don't think there's anyway to get it to work right... The
newer version uses a configuration file (NAPS-urlcache.txt) that can be
populated with current/valid cache servers to get onto the network...

{xmor61 at users dot sourceforge dot net}
Speak softly and carry a +6 two-handed sword.